Cannot compile in the new version of Rexygen Studio 2.50.8



  • Hello,

    I've recently updated both my laptop and desktop with the new version of Rexygen Studio. My desktop seems to be doing fine, but for whatever reason, my laptop does not want to compile any projects since then. I've tried reinstalling it multiple times and also tried uninstalling any dependencies it might have to then try to do a new Full installation. So far that didn't work, so I turn to here. My suspect is that I messed something somewhere when uninstalling the older version.

    I have tried to compile the exact same files on my desktop and they worked fine.

    Here's the output of a failed compilation:

    Processing project file C:\Users\Ivan\Documents\Rexygen\test_unit\test_unit_exec.mdl
    
    Generating RexHMI ...
      Source: C:\Users\Ivan\Documents\Rexygen\test_unit\hmisrc
      Destination: C:\Users\Ivan\Documents\Rexygen\test_unit\hmi
      Info: Processing index.hmi.svg file ...
      Error: Generating SVG file index.html failed!
      Error: "GenRexHMI.py "C:\Users\Ivan\Documents\Rexygen\test_unit\hmisrc" "C:\Users\Ivan\Documents\Rexygen\test_unit\hmi" "--clean" "--copy"" finished with error code 1
    Error: Generation of RexHMI failed: 1
    

    Also as a quick other question, I was wondering if it's possible to change my username to something like @sadilekivan, as I thought I'd be able to do that while registering but either I skipped it or did not get the chance to do it because I was just reporting my old profile.

    Thanks in advance, Ivan.



  • Hi Ivan,
    is the output folder "hmi" present? Is it empty? Try removing it completely prior to compilation.

    If this does not help, try running REXYGEN Studio as Administrator and see if you can compile your project. My guess is that there is some problem with write permissions.

    As for changing username, this cannot be done by the user. Our IT guys did it for you.

    Best regards,
    Jaroslav



  • @jaroslav_sobota
    Thanks for the swift username change.

    Unfortunately deleting the already existing "hmi" folder did no effect. I tried launching the Studio as an administrator with also no effect. The odd problem still persists.

    Any other advice? Also made sure again the files are right, I can compile them fine on my desktop. I've tried different files on my laptop and those cannot be compiled as well. I'd be sure there is something wrong with the files but I've reinstalled and cleaned the paths three times, so I think that part should be alright.

    Is it possible that the registry could cause this? I've also noticed I have a few extra python versions on my laptop since I experimented with micropython, but uninstalling them before fully installing REXYGEN had also no effect.


  • administrators

    Hello @sadilekivan ,
    I have a few questions. Can you check them for me.

    1. Are you able to compile the project without HMI on you laptop? Just uncheck the GenerateRexHMI in the HMI block. And compile it again.
    2. Are you able to build the HMI using HMI Designer?
    • Open the index.hmi.svg file in the REXYGEN HMI Designer tool.
    • Open REXYGEN HMI Configuration using CTRL+E shortcutn with no selection
    • In HTML export tab check Expert mode and change Output filename parameter to ../hmi/index.html
    • Close the dialog using OK button
    • Then press Ctrl+H for HMI generation from the HMI Designer.
    1. In HMI Designer check the python version and version of the libraries using Exensions -> REXYGEN HMI -> Version Info

    2. What is you Windows version?

    Thank you for your input,
    Best regards
    Ondrej



  • @ondrej_severa

    1. The project compiles fine without the HMI.

    2. I am unsure if the HMI compiles right in the designer since I don't get a message if it was successful. A little window only flashes and disappears. But since I don't get an explicit error message I assume it does export fine. My path was set to "hmi/index.html", I changed it to "../hmi/index.html" with no effect

    3. About the versions:

    • version: 2.50.8-10446
    • PyQt version: 5.9
    • Qt version: 5.9.7
    • SIP version: 4.19.13
    1. My laptop and Desktop are both running Windows 10 Pro.

    Hope these answers will give some insight, thanks in advance for the help.


  • administrators

    It seems that configuration of the HMI Designer is OK. Please check if HMI can be generated from the HMI Designer.

    • Delete the hmi directory
    • Open your index.hmi.svg
    • Generate the HMI using Ctrl+H
    • Check if hmi directory with index.html file was generated

    If this passed the problem is in the utility which calls the HMI Designer generator during compilation process in the Studio. I must prepare some better version of the script which will give us the detailed information about the error you receive.



  • @ondrej_severa
    I have compiled the index.hmi.svg and there is no index.html. It manages to compile some files but it doesn't create any .html


  • administrators

    Hello @sadilekivan ,
    this issue was caused by unknown bug in the hashing algorithm during the HMI build process. This will be fixed in next version of our software. Thank you for the bug report.

    Best regards
    Ondrej