Enabling Guest and Operator account



  • I found the below information about the additional accounts, like Super, Operator and Guest as listed below, but could not figure out how and where to change these settings.


    5.1 Users and Roles
    Following roles and permissions are defined:
    • admin - full permission set, a user with this role may perform any operation and
    has full control over the target device.
    • super - a user with this role can not perform any operation that has an impact on
    the target device ie. reboot the device, set system clock etc., but still may modify
    the running executive,
    • operator - a user with this role can not change the running executive but may read
    and change signal values,
    • guest - a user with this role can only read signal values and can not make any
    modifications.
    Only the admin role is enabled and the roles super, operator and guest are disabled by default. A user may enable those roles by setting options auth.super.enabled,
    auth.operator.enabled and auth.guest.enabled. For each role a user account with
    the respective name is present in the version 2.50.
    The authentication subsystem is enabled by default. A user may disable the authentication by the option auth.enabled. <snip>

    Hopefully you can help me to clarify this.

    Thanks in advance,
    Peter



  • Hi Peter,

    thanks for your question. You are right - there is missing the most important information - where to change these options - we will improve the docs.

    These settings can be changed by editing file rexcore.cfg. For more details see: https://www.rexygen.com/doc/ENGLISH/MANUALS/RexCore/RexCore_ENG.html#x1-50002.2
    Location of configuration files is described here:
    https://www.rexygen.com/doc/ENGLISH/MANUALS/RexCore/RexCore_ENG.html#x1-40002.1

    Regards,
    Tomas



  • Thanks a lot Tomas!
    Now I could enable the "guest" and "operator" and I can login as "guest", but it allows me to login without any password.
    Did not do it yet for "super" to see if all is working and the super has no access.
    So far this works.
    I neither know where to enter the password for the "guest" and for the "operator".

    This is how my rexcore.cfg file looks right now.
    3af8f92d-f456-4d4e-9c42-933ee4fe2d78-image.png

    On Rexygen Studio under the menu item Target, you can go to Change Password and you can change the current password for what I thought is only the administrator.
    e06d8276-57b1-4c10-913a-98ef60295cc7-image.png
    But where to do this for other users (guest, operator, super)?
    I neither see that in the options under rexcore.cfg

    Hopefully you can guide me (and others) further on this.

    Thanks in advance,
    Peter



  • Sorry, I found it!
    This has to be done when you connect to the target in Rexygen Studio as "guest" instead of "admin" with empty password.
    c9fb1be4-af4c-4db7-861e-45e3a36aa60c-image.png
    Afterwards, you can enter a new password as mentioned above, so in this screen.
    Current password empty and you can create a new password for the "guest" by entering 2 times the password you want.
    155bbd42-ca13-4c4a-bb08-85607d652cfc-image.png
    Same situation also applies for other users (operator and super).

    Regards,
    Peter



  • Hi Peter,

    Thanks for sharing the solution you found - it is absolutely right - well done!

    Cheers,
    Tomas



  • Hi Tomas,
    Despite the fact the access was working well with different levels and I wrote down the passwords assigned to the "guest", "operator" and "super" user, I no longer can login with the credentials created, neither with a black password.
    Only my "admin" and belonging password is still working.

    I figured out you can clear or reset the passwords for the different levels by simply removing the "auth.rex" file from the rex/rexcore filder.
    In order to try it out, I renamed the existing file to "org_auth.rex", so it was no longer recognized by the system.
    On the command prompt I used: sudo mv auth.rex org_auth.rex

    Of course you also can remove the file instead of renaming it.

    After a system reboot you can login with "admin" without using a password and you also can login as guest, operator or super user without using a password.
    The new password can be set as mentioned in the above listed post in this forum.

    Peter



  • Hi,

    My RPi was not running anymore and I could not connect using Rexygen.
    I tried all with admin and all passwords I ever used before, including no password at all (the default), but all without success. I was able to SSH into the Raspberry.
    Based on the above item about removing or renaming the "auth.rex" file to start with a blank password, I checked the rex/rexcore folder, but noticed that this "auth.rex" file does not excist.

    So does this mean I need to start from scratch to be able to login again? Removing Rexygen and freshly installing it?

    Looking forward to hear from you.
    Peter



  • Hi Peter,

    what changed between your two last posts? First one says you were able to login after renaming the auth.rex file and the second says you are not able to login anymore? Do you remember what did you do in between?

    Anyway I would also suggest to remove (better "apt-get purge") and install again. This will remove all the configuration files so be sure to backup any important beforehead.

    Let me know if you were able to make it running again.

    Cheers,
    Tomas



  • Hi Tomas,

    This is a different Raspberry ...
    I don't know what happened, but nevertheless I am sure I will be able to fix it again.
    I will try your approach and update you accordingly.

    Best regards,
    Peter



  • Hi Tomas,

    I tried your proposal, but unfortunately it did not work.
    At the end I decided to simply re-image the SD card and start from scratch. Installed the most recent Rexygen test version and now, all is working fine.
    Thanks for your support.

    Best regards,
    Peter


Log in to reply