Problem with uploaded software

  • Hi,
    I have a problem with the software uploaded to RexCore. I have RexCore deployed on Raspberry PI 3B, NOOBS 3.4.0. A project created in Rexygen Studio uploaded to the kernel without errors. However, the SW works as if in slow motion / partially. The HMI runs, but the SW does not read the data. Below I attach an extract from the System Log. Please advise what the problem is. The SW is inserted in the appendix.
    Michal Tomek
    200816_system log.JPG

  • Hi,
    so i realized there could be a problem in that I updated RaspberryPI to the latest kernel version. So I probably need to install the latest version of Rexygen. The above information about the RexCore version is therefore incorrect (I don't even know where to find the RexCore version). So I installed the version Rexygen REXYGEN- After translation, some blocks were updated. However, I have error when translating and I can't find it.
    Michal Tomek
    200817_system log.JPG

  • Hi Michal,

    thank you for reaching out. Since REXYGEN 2.50.9 version there were introduced some changes in naming conventions that are not reflected in REXduino source files yet.

    Please, download following REXduino source code to your project directory (replace the old one) and try to Compile and Download the project again.


    Please, let me know if it worked for you.


  • Hi Tomas,
    I downloaded the new source code and translated it again. The translation is already without error. But communication between RaspberryPI and Arduino still doesn't work. Visualization works, but measurement data doesn't come and commands to peripherals don't work. There are still the same errors in the log as in the first post. In my opinion, it looks like a communication error over the serial line. RaspberryPI tries to communicate with Arduino, sometimes blinking led on Arduino, but not always blinking as before. The "Arduino_Mega2560hex" function block constantly lists the following states over and over: comm_status 1 then 2, err_code 0 then 49, err_subcode 0 then 52. I do not know their meaning.

  • Hello Michal,
    the error codes are listed in the REXduino_slave.ino file. The codes you provided mean some problem with pin number. However, you are using an outdated version of REXduino so no guarantee...

    Therefore, as the first step, I recommend upgrading to the newest REXduino. I have just pushed a hotfix for the naming conflict to REXduino GitHub so you should be able to use it with any version of REXYGEN.

    Please try compiling and running the included example 51. Make sure to upgrade your Arduino as well.

    Let me know if it helped.

    Best regards

  • Hi Jaroslav,
    I downloaded REXduino Version 2.0.2. Everything now works without problems.
    Best regards.
    PS: Pavel Kotrba greets you 😉

Log in to reply