Replacing typed characters for "***" while typing a password



  • Hi,

    I"m wondering if there is an example how you can replace characters when typing. Like you do for many websites when entering a password.
    So I want to use a typed string from the HMI in the "task" block, but want to replace the typed characters with "***" characters.

    Looking forward for feedback on this.

    Best regards,
    Peter



  • Hello Peter,
    so far this feature is not available yet, but it will be soon. Just little recommendation. If you are about to use passwords in your HMI I strongly recommend to switch from HTTP to HTTPS protocol.
    Just visit the https//: 127.0.0.1:8009 (mind the different port) and your communication between web browser and REGYGEN web server will be encrypted.

    Best regards,
    Ondrej



  • @ondrej_severa
    Thanks a lot for your feedback and looking forward for the update to make this possible.
    Thanks for the tip about https usages!

    Best regards,
    Peter



  • @ondrej_severa
    Hi Ondrej,

    Is there any news on this new feature spoken about in the thread before (replacing characters for “*” when entering a “password”?
    My intension is using that for the HMI page to enter for instance a configuration page that normally should not be meshed up by anyone.

    Thanks in advance,
    Best regards,
    Peter



  • Hi Peter,

    the feature is now available in pre-release version 2.50.10-r5. Do you want to try it out or better wait for public release version?

    Regards, Ondrej



  • @ondrej_severa

    Hi Ondrej,

    That sounds promising and I like to try it out!
    I am currently already on a pre-released Version V 2.50.10.11464.
    Or is it also available in that release already?

    Regards,
    Peter



  • Yes this feature is already included in your pre-release version. Just use HMI Designer and use Input component. You have to change format to password.
    Best regards
    Ondrej



  • Hello Ondrej,

    This is really nice!
    Looks great, thanks a lot!

    Best regards,
    Peter



  • Hi Ondrej,

    I tried also to enable the HTTPS protocol, but don't succeed.
    According to the information I should change the rexcore.cfg file.

    rexcore_file_setting.PNG

    So based on the description "option=value" I would expect this should be working.
    HTTPS_connection_setting.PNG

    But this last line in the file is NOT doing the job. I have (after reboot) no connection to the HMI on port 8009.

    Or is there anything else that needs to be enabled to achieve this?

    Regards,
    Peter



  • Hi Peter,

    the HTTPS server is enabled by default on port 8009 - there is no need to change the rexcore.cfg unless you want to change the port.

    The HMI should be accessible at

    https://YOUR_RPI_IP:8009/
    

    Be sure to write explicitly https and the ending /.

    Regards,
    Tomas



  • Hi Tomas,

    Great, this works. Thanks a lot for the feedback and to get it going!

    Peter


Log in to reply