got some errors during installing REXYGEN for UniPi



  • Re: New Raspbian Version Buster was released this month

    Followed the installation for UniPi and got some errors:

    Setting up owserver (3.2p3+dfsg1-2) ...
    Job for owserver.service failed because the service did not take the steps required by its unit configuration.
    See "systemctl status owserver.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript owserver, action "start" failed.
    ā— owserver.service - Backend server for 1-wire control
    Loaded: loaded (/lib/systemd/system/owserver.service; disabled; vendor preset: enabled)
    Active: activating (auto-restart) (Result: protocol) since Wed 2019-07-31 21:48:45 CEST; 231ms ago
    Docs: man:owserver(1)
    Process: 662 ExecStart=/usr/bin/owserver -c /etc/owfs.conf (code=exited, status=0/SUCCESS)
    Main PID: 662 (code=exited, status=0/SUCCESS)

    Jul 31 21:48:45 raspberrypi03 systemd[1]: owserver.service: Service RestartSec=100ms expired, scheduling restart.
    Jul 31 21:48:45 raspberrypi03 systemd[1]: owserver.service: Scheduled restart job, restart counter is at 1.
    Jul 31 21:48:46 raspberrypi03 systemd[1]: Stopped Backend server for 1-wire control.
    dpkg: error processing package owserver (--configure):
    installed owserver package post-installation script subprocess returned error exit status 1
    dpkg: dependency problems prevent configuration of rex-owsdrvt:
    rex-owsdrvt depends on owserver; however:
    Package owserver is not configured yet.

    dpkg: error processing package rex-owsdrvt (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of rexygen-runtime:
    rexygen-runtime depends on rex-owsdrvt (= 2.50.9-10679~Raspbian~stretch); however:
    Package rex-owsdrvt is not configured yet.

    dpkg: error processing package rexygen-runtime (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    owserver
    rex-owsdrvt
    rexygen-runtime
    E: Sub-process /usr/bin/dpkg returned an error code (1)



  • Hi,
    thanks for reporting this. The problem is with owserver installation in Buster.

    Can you try running

    sudo dpkg --configure -a
    

    We'll definitely try to reproduce the problem here on our testbench in the next week. Will get back to you.

    Kind regards,
    Jaroslav



  • Hi,
    I am not able to reproduce the problem. With the latest installation scripts, everything gets installed correctly.

    Any updates on your side?

    Best regards,
    Jaroslav



  • @jaroslav_sobota

    After installing Buster Lite Image I made manual install of owserver.
    sudo apt install owserer
    During that install I got the same error messages.
    Reboot and install rex with unipi script.
    Everything was installed without any error.
    Raspi is up and running without any issues.